use -keepclasseswithmembers instead of -keepclasseswithmembernames

SDKをアップデートしたら以下のようなエラーが出た。

Obsolete proguard file; use -keepclasseswithmembers instead of -keepclasseswithmembernames	proguard.cfg	/com.example	line 1	Android Lint Problem

■対策

proguard.cfgをテキストエディタで開くと-keepclasseswithmembersというフラグが(3箇所くらい)あるので-keepclasseswithmembernamesに修正する。Window > Show View > Android > Lint Warnings のウィンドウのrefreshボタンを押す。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です